IRFU problems (bugs)

Open Source software contributions and discussions that supplement or extend the Palette / Light Palette software
User avatar
mat
Posts: 448
Joined: Thu Nov 15, 2007 12:05 pm
Primary Venue / Use: Professional Theatre
Where I Am: An opera in France
Location: Dijon;France
Contact:

Re: IRFU problems (bugs)

Post by mat » Mon Jul 11, 2016 12:25 pm

Hi Mick

Thanks for the answer,
I would love this bug to be fixed!

I think it's the IOS update that broke something...
Mat-Opera de Dijon
France
lightpalette VL
palette VL 16
10.8.8

User avatar
MickCrozier
Posts: 288
Joined: Tue Mar 31, 2009 3:10 am
Primary Venue / Use: Professional Theatre
Where I Am: Melbourne, Australia
Location: Melbourne, Australia

Re: IRFU problems (bugs)

Post by MickCrozier » Tue Jul 19, 2016 7:59 am

I ran it up and found it crashing a lot under ios9 so I've spent a couple of days getting v2 up to a release standard, it's not as refined as v1 but brings in compatibility for the various screen sizes. Should be available soon.

As for the output bug, I'll have to play around with it when I get more time. But it appears to be an issue with Palette - irfu code sends the address as it is typed. '1.1' for 1, '1.50' for 50, therefore should do '2.1' as 513. But it doesn't work. I'm sure this used to...
Formerly Durisian (who died peacefully of digital old age)

GaryDouglas
Posts: 689
Joined: Thu Oct 11, 2007 9:33 pm
Location: Calgary, Canada

Re: IRFU problems (bugs)

Post by GaryDouglas » Tue Jul 19, 2016 11:44 am

I can look into the output spec issue.

What is the exact LUA command that you're sending? This will help me narrow it down....

Thanks!
Gary Douglas - Lead Software Developer - Pathway Connectivity - A Division of Acuity Brands Lighting Canada.

User avatar
MickCrozier
Posts: 288
Joined: Tue Mar 31, 2009 3:10 am
Primary Venue / Use: Professional Theatre
Where I Am: Melbourne, Australia
Location: Melbourne, Australia

Re: IRFU problems (bugs)

Post by MickCrozier » Tue Jul 19, 2016 9:11 pm

Argh!!!
Thanks Gary but it's my bad - Turns out I am translating 2.1 to 513, well, not properly anyway :mrgreen:
Fix being uploaded to Apple as I type
Formerly Durisian (who died peacefully of digital old age)

User avatar
mat
Posts: 448
Joined: Thu Nov 15, 2007 12:05 pm
Primary Venue / Use: Professional Theatre
Where I Am: An opera in France
Location: Dijon;France
Contact:

Re: IRFU problems (bugs)

Post by mat » Wed Jul 20, 2016 11:31 am

It has been updated on the apple store, I am in long holidays but I will test it when I am back late august.

Thank you very much for it!

nice new skin of the app by the way...
Mat-Opera de Dijon
France
lightpalette VL
palette VL 16
10.8.8

User avatar
mat
Posts: 448
Joined: Thu Nov 15, 2007 12:05 pm
Primary Venue / Use: Professional Theatre
Where I Am: An opera in France
Location: Dijon;France
Contact:

Re: IRFU problems (bugs)

Post by mat » Mon Aug 22, 2016 1:46 pm

well, I tested it today and it works nice for the outputs!

but 2 things:
- on my Ipad mini, when you turn the screen to access the subs it doesn't go back to portrait correctly.Very annoying
It is ok on my iphone

- in outputs mode you can't do: 50@30 enter
It does: 50@off


thanks
Mat-Opera de Dijon
France
lightpalette VL
palette VL 16
10.8.8

User avatar
golights
Posts: 159
Joined: Mon Feb 04, 2008 2:58 pm
Location: South Of Atlanta

Re: IRFU problems (bugs)

Post by golights » Thu Oct 27, 2016 4:03 pm

The problem with turning the screen to access the subs and not going back to portrait correctly in not working on my I phone.
Could you look at this please.

Post Reply